J'ai créé une nouvelle application Rails (v5.2.4.3) à l'aide de Ruby 2.7.1 et j'ai découvert le blizzard des avertissements de "paramètre de mot-clé" endémiques dans cette version.

rbenv install --list, pour une raison quelconque, ne répertorie pas les versions de Ruby au-delà de la 2.4.0. J'ai installé manuellement 2.6.6 mais je suis incapable de le lancer.

Cela semble être un problème simple. Astuces?

1
Brian Piercy 26 août 2020 à 03:55

2 réponses

Meilleure réponse

Vous devez d'abord vérifier la version du plugin 'ruby-build':

cd ~/.rbenv/plugins/ruby-build
git log

Si vous n'avez pas de répertoire ~/.rbenv/plugins, il est peut-être trop ancien pour la version de votre rbenv. Première mise à jour de rbenv:

cd ~/.rbenv
git pull

Ensuite, installez le plugin 'ruby-build':

git clone https://github.com/rbenv/ruby-build.git ~/.rbenv/plugins/ruby-build
4
Run 28 août 2020 à 05:15

Il semble que vous devriez l'installer via rbenv:

rbenv install 2.6.6
1
Adobe 26 août 2020 à 04:13