J'ai mis à jour la version 2.0 d'Android Studio et je l'utilisais normalement. Lorsque j'ai créé un nouveau projet aujourd'hui, il affiche l'erreur Le plug-in est trop ancien, veuillez mettre à jour vers une version plus récente ou définir la variable d'environnement ANDROID_DAILY_OVERRIDE sur

J'ai réalisé que ce problème ne se produit que lorsque je crée un nouveau projet. Dans les projets précédents développés, le problème ne se pose pas et j'ai réalisé que gradle est différent classpath 'com.android.tools.build:gradle:1.3.0'.

Je dois mettre à jour avec le même ensemble d'anciens projets?

Mon application / build.gradle

apply plugin: 'com.android.application'

android {
compileSdkVersion 23
buildToolsVersion "23.0.2"

defaultConfig {
    applicationId "luizugliano.com.br.teste"
    minSdkVersion 16
    targetSdkVersion 23
    versionCode 1
    versionName "1.0"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
  }
}

dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
testCompile 'junit:junit:4.12'
compile 'com.android.support:appcompat-v7:23.1.1'
compile 'com.android.support:design:23.1.1'
}

Mon build.gradle (projet)

// Top-level build file where you can add configuration options common to all    sub-projects/modules.

buildscript {
  repositories {
    jcenter()
}
dependencies {
    classpath 'com.android.tools.build:gradle:2.0.0-alpha1'

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
  }
}

allprojects {
  repositories {
    jcenter()
  }
}

task clean(type: Delete) {
  delete rootProject.buildDir
}
72
Luiz Henrique Ugliano 3 janv. 2016 à 04:21

15 réponses

Meilleure réponse

UH OH, Google Avis: "Ce site Web ne propose plus de téléchargements pour Android Studio."

(Les anciens liens de "chaîne" ne fonctionnent plus. Les liens de cette réponse ont été mis à jour vers les nouveaux formats, assurez-vous de modifier vos favoris si vous les utilisiez)

Vous devez mettre à jour la version des outils Gradle avec lesquels vous créez. Ceci peut être trouvé dans la section des dépendances de votre build.gradle. Vous avez 3 options que vous pouvez mettre à jour :

La dernière version stable référencée dans la version de la version à partir du 2ème Mars 2017 est

classpath 'com.android.tools.build:gradle:2.3.0' 

Ou la dernière version bêta via aperçu chaîne au 15 février 2017 est

classpath 'com.android.tools.build:gradle:2.3.0-beta4'

Et la dernière version alpha également à partir de aperçu de la chaîne à partir du 21 mars 2017 vous offre la possibilité d'utiliser

classpath 'com.android.tools.build:gradle:2.4.0-alpha3' 

La mise à jour vous oblige également à mettre à niveau le encapsuleur de gradle. Depuis le 20 février 2017, le plus récent est:

distributionUrl=https\://services.gradle.org/distributions/gradle-3.4-all.zip

Sur Android Studio, vous pouvez trouver votre wrapper en passant à la vue du projet et en regardant dans gradle / wrapper / gradle-wrapper.properties

Parfois, après avoir changé de wrapper, le projet échoue à se compiler avec une erreur comme “Minimum supported Gradle version is 2.14.1. Current version is 2.10. Try changing Gradle distribution version to...” bien qu'il ait déjà la bonne version dans gradle-wrapper.properties. Si cela se produit, essayez ce qui suit:

Accédez à Paramètres & gt; Construction, exécution, déploiement & gt; Gradle

Sous Project-level settings, assurez-vous que Utiliser le wrapper de gradle par défaut (recommandé) est l'option sélectionnée, puis reconstruisez votre projet.

(Note supplémentaire: en ce qui concerne les versions alpha et bêta - il n'y a pas toujours une version plus récente que la version stable lorsque je vérifie, dans ces cas, je viens de donner des valeurs pour la version précédente. Cela vous permet de rouler revenir à cette version si vous rencontrez des problèmes avec la version publiée)

131
Community 20 juin 2020 à 09:12

Dans un nouveau projet, changez cette partie:

dependencies {
    classpath 'com.android.tools.build:gradle:2.0.0-alpha1'

Avec

dependencies {
    classpath 'com.android.tools.build:gradle:1.5.0'.

Si vous n'êtes pas un utilisateur expérimenté, veuillez vous en tenir au canal stable des mises à jour d'Android Studio. Je suppose que vous avez Android Studio de Canary Channel.

Notez que:

The Canary Channel pour Android Studio propose des mises à jour de pointe sur une base hebdomadaire environ. Bien que ces versions soient testées, ils sont toujours sujets à des bugs, car nous voulons que les gens voient les nouveautés dès que possible.

De: http://tools.android.com/download/studio/canary

Vous n'avez pas besoin de modifier les dépendances de vos anciens projets. Ils devraient fonctionner normalement sur la dernière version.

26
Community 20 juin 2020 à 09:12

Même problème lors de la mise à jour. cela a résolu le problème pour moi: [build.gradle]

    classpath 'com.android.tools.build:gradle:2.0.0-alpha3'

Ou

    classpath 'com.android.tools.build:gradle:2.0.0-beta2'
12
SonniE 1 mars 2016 à 04:40

Juste dans les paramètres système avancés des propriétés Windows, ajoutez une nouvelle variable d'environnement avec le nom ANDROID_DAILY_OVERRIDE et la valeur donnée dans le message d'erreur. Redémarrez Android Studio et vous serez prêt à partir

enter image description here

7
Luka Kerr 26 oct. 2016 à 05:01

Depuis le 5 avril 2016, cela a fonctionné pour moi:

classpath 'com.android.tools.build:gradle:2.0.0-rc3'
5
j2abro 6 avril 2016 à 00:25

La version gradle dont vous avez besoin est devenue

classpath 'com.android.tools.build:gradle:2.0.0-beta7'

Ce qui vous oblige à utiliser le wrapper gradle pour 2.10 si vous utilisiez toujours la version précédente

distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip

Sur Android Studio, vous pouvez trouver votre wrapper en passant à la vue du projet et en regardant dans gradle/wrapper/gradle-wrapper.properties

3
Muhammad Waleed 5 déc. 2016 à 11:55
classpath: com.android.tools.build:gradle:+

Cela résoudra le problème en mettant à jour gradle vers le dernier.

Cependant, il est dangereux (codera en phase alpha) et donnera également des avertissements.

2
Sanyam Jain 7 janv. 2016 à 10:24

Si vous utilisez Android Studio 2.0 Preview, je peux suggérer d'utiliser le canal de mises à jour «bêta» au lieu de «stable». Il vous permettra de recevoir les dernières modifications de configuration de gradle. Vous pouvez changer de chaîne de mise à jour dans Settings - Appearance & Behavior - System Settings - Updates. Sélectionnez Automatically check updates for [Beta Channel]

Pour connaître la version actuelle de gradle classpath et distributionUrl (consultez la réponse de Nick Caroso), vous peut créer un nouveau projet vide et y voir ces valeurs.

2
Community 23 mai 2017 à 12:02

Vous devez modifier votre fichier gradle-wrapper.properties dans le dossier gradle / wrapper de votre application, changez votre distributionUrl comme suit:

distributionUrl=http\://services.gradle.org/distributions/gradle-2.8-all.zip

Utilisez http: ou https: \ selon vos besoins. Ensuite, nettoyez simplement votre projet et vous avez terminé !!!

Note latérale:

classpath 'com.android.tools.build:gradle:2.0.0-alpha3'

Est disponible maintenant, si vous souhaitez utiliser la dernière version.

Vous pouvez également profiter de la fonction d'exécution instantanée d'Android Studio en utilisant ceci, qui n'est pas disponible dans la version gradle inférieure à 2.0.0

1
vivek vekariya 7 janv. 2016 à 19:17

Essayez de mettre à jour gradle à 2.10

Pour mac, le chemin est Android Studio> Préférences> Builds, Execution, Deployment> Build Tools> Gradle

Bien sûr, vous devez télécharger gradle 2.10 avant

1
yfsx 16 mars 2016 à 03:02

J'ai eu la même erreur le 04/07/2016 avec 'com.android.tools.build:gradle:2.2.0-alpha2' et le wrapper gradle 2.10 alors, je viens de changer pour

'com.android.tools.build:gradle:2.2.0-alpha3'

Maintenant je n'ai aucun problème.

J'espère que cela aidera les gens.

1
Vrian7 5 juil. 2016 à 10:30

Changez simplement le chemin de classe 'com.android.tools.build:gradle:2.0.0-alpha' ou

classpath 'com.android.tools.build:gradle:2.1.0'
0
Abolfazl Miadian 16 mai 2016 à 11:13

Je change mon classpath de 'com.android.tools.build:gradle:2.2.0-alpha4'

Au chemin de classe 'com.android.tools.build:gradle:2.2.0-alpha5'

Et cliqué sur "try_again" lorsque l'avertissement apparaît "impossible de trouver le chemin de classe mis en cache" vous cliquez simplement sur "sync", cela a fonctionné comme un jeu d'enfant.

0
joe 1 août 2016 à 06:35

Ce problème se produit généralement lorsque l'EDI (studio android) dans lequel le projet est construit et le projet ne sont pas dans un plug-in gradle compatible. Veuillez vérifier le lien ci-dessous http://tools.android.com/tech-docs/new -construction-système / compatibilité de version

Dans mon cas, j'avais créé un projet en utilisant la version AS 1.0 / 2.0, et plus tard importé dans la version studio nouveau, cela m'a donné une erreur, puis j'ai ouvert le projet dans l'ancienne version de AS cela fonctionnait. vous pouvez également consulter http://tools.android.com/tech-docs/new -construction-système

0
maruti060385 27 août 2016 à 18:44

Fichier -> Structure du projet -> Projet -> Version du plugin Android = 2.2.3

Fonctionnement bien d'Android Studio 2.2.3

0
Android Dev 14 juin 2017 à 08:35