enter image description here

Ces lignes ondulées rouges indiquent cannot find module 'angular2/core', cannot find module 'angular2/router', cannot find module 'angular2/http'. J'ai vérifié d'autres messages dans SO mais il semble qu'ils n'aient pas de réponse appropriée.

J'ai également ajouté une référence aux fichiers d.ts comme indiqué ci-dessous mais ne fonctionne toujours pas. entrez la description de l'image ici

D'autres articles disent que j'ai besoin de configurer quelque chose dans le fichier tsconfig.json mais j'utilise Visual Studio et je ne vois pas besoin d'utiliser le tscompiler suggéré par l'équipe angular car Visual Studio devrait être capable de compiler les fichiers ts automatiquement.

Suis-je en train de manquer quelque chose?

Le tsconfig.json est-il toujours nécessaire même si vous utilisez Visual Studio?

Comment puis-je me débarrasser de ces lignes ondulées?

Merci!

(J'utilise Visual Studio 2015 et le dernier moteur Typescript)

METTRE À JOUR: Je ne sais pas ce qu'est exactement le gestionnaire de paquets npm. Mais j'ai un fichier package.json pré-construit qui a été créé lors de la création du projet. J'utilise ce fichier pour installer les packages npm. entrez la description de l'image ici

62
raberana 28 déc. 2015 à 09:27

14 réponses

Meilleure réponse

Pour les applications ASP.NET 5.0 dans VS 2015, la configuration du typographie est un peu difficile.

Jusqu'à ce que l'outillage autour du manuscrit s'améliore, vous pouvez configurer le manuscrit manuellement:

Step 1: Right-click project, and Unload Project 
Step 2: Right-click the unloaded project, and Edit the .xproj file
Step 3: Add a PropertyGroup node, under the Project node:

  <PropertyGroup Condition="'$(Configuration)' == 'Debug'">
    <TypeScriptTarget>ES5</TypeScriptTarget>
    <TypeScriptJSXEmit>None</TypeScriptJSXEmit>
    <TypeScriptCompileOnSaveEnabled>True</TypeScriptCompileOnSaveEnabled>
    <TypeScriptNoImplicitAny>False</TypeScriptNoImplicitAny>
    <TypeScriptModuleKind>CommonJS</TypeScriptModuleKind>
    <TypeScriptRemoveComments>False</TypeScriptRemoveComments>
    <TypeScriptOutFile />
    <TypeScriptOutDir />
    <TypeScriptGeneratesDeclarations>False</TypeScriptGeneratesDeclarations>
    <TypeScriptNoEmitOnError>True</TypeScriptNoEmitOnError>
    <TypeScriptSourceMap>True</TypeScriptSourceMap>
    <TypeScriptMapRoot />
    <TypeScriptSourceRoot />
    <TypeScriptExperimentalDecorators>True</TypeScriptExperimentalDecorators>
  </PropertyGroup>

Step 4: Right-click the unloaded project and Reload Project
Step 5: Re-build project

Si vous rencontrez toujours l'erreur où il ne peut pas trouver le module, quittez Visual Studio et rechargez la solution.

53
pixelbits 28 déc. 2015 à 08:26

Voici mes paramètres de travail:

<PropertyGroup Condition="'$(Configuration)' == 'Release'">
  <TypeScriptTarget>ES5</TypeScriptTarget>
  <TypeScriptJSXEmit>None</TypeScriptJSXEmit>
  <TypeScriptCompileOnSaveEnabled>True</TypeScriptCompileOnSaveEnabled>
  <TypeScriptNoImplicitAny>False</TypeScriptNoImplicitAny>
  <TypeScriptModuleKind>System</TypeScriptModuleKind>
  <TypeScriptRemoveComments>False</TypeScriptRemoveComments>
  <TypeScriptOutFile />
  <TypeScriptModuleResolution>NodeJs</TypeScriptModuleResolution>
  <TypeScriptOutDir />
  <TypeScriptGeneratesDeclarations>False</TypeScriptGeneratesDeclarations>
  <TypeScriptNoEmitOnError>True</TypeScriptNoEmitOnError>
  <TypeScriptSourceMap>True</TypeScriptSourceMap>
  <TypeScriptMapRoot />
  <TypeScriptSourceRoot />
  <TypeScriptEmitDecoratorMetadata>True</TypeScriptEmitDecoratorMetadata>
  <TypeScriptExperimentalDecorators>True</TypeScriptExperimentalDecorators>
</PropertyGroup>

Redémarrez Visual Studio après l'avoir appliqué à votre projet Web.

9
Loïc Lopes 22 févr. 2017 à 16:22

Pour VS2015, allez dans Outils -> Options -> Editeur de texte -> TypeScript -> Projet -> Général puis cochez "Compiler automatiquement les fichiers TypeScript qui ne font pas partie d'un projet" puis sélectionnez "Utiliser la génération de code CommonJS pour les modules."

7
Ron 9 juin 2016 à 15:23

Voici comment j'ai résolu le problème dans VS2015:

  • Ouvrir la fenêtre des propriétés du projet
  • Accédez à l'onglet TypeScript Build
  • Sélectionnez CommonJS comme système de module comme indiqué dans l'image ci-dessous

enter image description here

6
Sharif 5 févr. 2016 à 04:02

J'ai aussi rencontré cette erreur et ce qui a fonctionné pour moi était le déchargement du projet et la vérification du fichier .csproj. J'ai trouvé que cet extrait a été ajouté là-bas -

  <ItemGroup>
    <None Remove="ClientApp\components\componentname\componentname.ts" />
  </ItemGroup>

La suppression de ce code, l'enregistrement du csproj puis le rechargement du projet ont fonctionné. J'espère que cela t'aides!

1
NamrataP 26 sept. 2018 à 09:35

Le moyen le plus simple de l'installer est d'utiliser le gestionnaire de paquets npm, car angular2 est livré avec la saisie maintenant. Votre éditeur reconnaîtra tous les emplacements d'importation ...

0
Vlado Tesanovic 28 déc. 2015 à 07:37

J'ai eu ce problème lors de l'installation d'ionic 2 - j'ai installé tous les packages (mise à jour package.json) et mis à jour mon npm vers la v3. Cela l'a résolu.

0
Ashwin G 29 sept. 2016 à 18:50
This has to be done for both 'Debug' and 'Release' then only it works in VS 2013. Like below..

<PropertyGroup Condition="'$(Configuration)' == 'Release'">
    <TypeScriptTarget>ES5</TypeScriptTarget>
    <TypeScriptJSXEmit>None</TypeScriptJSXEmit>
    <TypeScriptCompileOnSaveEnabled>True</TypeScriptCompileOnSaveEnabled>
    <TypeScriptNoImplicitAny>False</TypeScriptNoImplicitAny>
    <TypeScriptModuleKind>system</TypeScriptModuleKind>
    <TypeScriptRemoveComments>False</TypeScriptRemoveComments>
    <TypeScriptOutFile />
    <TypeScriptModuleResolution>NodeJs</TypeScriptModuleResolution>
    <TypeScriptOutDir />
    <TypeScriptGeneratesDeclarations>False</TypeScriptGeneratesDeclarations>
    <TypeScriptNoEmitOnError>True</TypeScriptNoEmitOnError>
    <TypeScriptSourceMap>True</TypeScriptSourceMap>
    <TypeScriptMapRoot />
    <TypeScriptSourceRoot />
    <TypeScriptEmitDecoratorMetadata>True</TypeScriptEmitDecoratorMetadata>
    <TypeScriptExperimentalDecorators>True</TypeScriptExperimentalDecorators>
</PropertyGroup>

<PropertyGroup Condition="'$(Configuration)' == 'Debug'">
    <TypeScriptTarget>ES5</TypeScriptTarget>
    <TypeScriptJSXEmit>
    </TypeScriptJSXEmit>
    <TypeScriptCompileOnSaveEnabled>True</TypeScriptCompileOnSaveEnabled>
    <TypeScriptNoImplicitAny>False</TypeScriptNoImplicitAny>
    <TypeScriptModuleKind>system</TypeScriptModuleKind>
    <TypeScriptRemoveComments>False</TypeScriptRemoveComments>
    <TypeScriptOutFile />
    <TypeScriptModuleResolution>NodeJs</TypeScriptModuleResolution>
    <TypeScriptOutDir />
    <TypeScriptGeneratesDeclarations>False</TypeScriptGeneratesDeclarations>
    <TypeScriptNoEmitOnError>True</TypeScriptNoEmitOnError>
    <TypeScriptSourceMap>True</TypeScriptSourceMap>
    <TypeScriptMapRoot />
    <TypeScriptSourceRoot />
    <TypeScriptEmitDecoratorMetadata>True</TypeScriptEmitDecoratorMetadata>
    <TypeScriptExperimentalDecorators>True</TypeScriptExperimentalDecorators>
</PropertyGroup>
0
bbsimonbb 21 oct. 2016 à 11:26

Développement avec le modèle ASP.NET Core Angular 2 Starter Application de Mads Kristensen. J'ai eu un problème similaire en démarrant un nouveau répertoire avec des fichiers Typescript.

Ma solution était plus simple que de modifier le fichier projet. Je viens de copier le tsconfig.json du dossier ClientApp où tous les fichiers dactylographiés se trouvaient dans mon nouveau dossier.

0
villecoder 2 févr. 2017 à 14:32

Faites un clic droit sur " package.json "

Et sélectionnez " Restaurer les packages " après l'installation de Packages, construisez-le ... votre problème est résolu

0
Vipul Upadhyay 15 févr. 2017 à 14:44

C'est un problème intéressant, mis à part les raisons et la solution mentionnées ci-dessus, on peut obtenir cette erreur dans les scénarios suivants.

  1. NPM (Node Package Manager) n'est pas installé sur la machine

    Correction: Installez NPM à partir de https://nodejs.org/en/

    Probablement NPM non installé ou non configuré

  2. Si vous obtenez toujours cette erreur après l'installation de NPM, il peut y avoir un problème de configuration de NPM. Reportez-vous à cet article pour configurer correctement la configuration NPM.

0
Venkatesh Muniyandi 2 mai 2017 à 10:37
  1. Dans Visual Studio 2015, allez dans le menu "Outils" et cliquez sur "Options ...". Vous pourrez voir une structure arborescente sur le côté gauche de la fenêtre ouverte.
  2. Développez "Projets et solutions", puis sélectionnez "Outils Web externes". Déplacez maintenant l'entrée "$ (PATH)" au-dessus de l'entrée "$ (DevEnvDir)".
  3. Cliquez sur OK. Redémarrez Visual Studio.
  4. Maintenant, faites un clic droit sur le fichier "package.json" dans l'explorateur de solutions et cliquez sur "Restaurer les packages".
0
Nithin Thampi 27 juin 2017 à 11:55

Salut, j'ai le même problème lorsque j'utilise l'éditeur eclplse. J'ai exécuté la commande ci-dessous dans ma fenêtre cmd et j'ai redémarré mon eclipse. Cela fonctionne comme prévu.

npm install --save @ angular / core @ angular / compiler @ angular / common @ angular / platform-browser @ angular / platform-browser-dynamic rxjs@5.0.0-beta.6 zone.js@0.6.12 @ angular / forms

0
Sagar 29 juin 2017 à 11:26

Faites un clic droit sur " package.json " puis sélectionnez l'option Installer les packages, cela ouvrira le terminal et naviguera automatiquement vers le dossier racine correct et installera les dépendances requises.

Le package.json répertorie toute la liste des dépendances dont le projet a besoin pour s'exécuter.

0
Balavignesh 20 juin 2019 à 08:22