J'installe déjà le modèle Yii2 Advanced via une archive et je crée déjà la moitié de mon application, mais maintenant je veux installer une bibliothèque qui peut simplement être installée via composer, donc j'ai également installé composer, mais maintenant comment puis-je installer une bibliothèque pour mon yii2 projet utilisant ce compositeur?

0
Pandu Pratama Nur 4 janv. 2016 à 12:33

2 réponses

Meilleure réponse

Exécutez la commande:

composer global require "fxp/composer-asset-plugin:~1.1.1"

Depuis le guide d'installation (http: // www. yiiframework.com/doc-2.0/guide-start-installation.html#installing-via-composer) pour obtenir le package bower et npm via Composer, puis créez un fichier composer.json , un exemple d'une installation de modèle avancé propre:

{
    "name": "yiisoft/yii2-app-advanced",
    "description": "Yii 2 Advanced Application Template",
    "keywords": ["yii2", "framework", "advanced", "application template"],
    "homepage": "http://www.yiiframework.com/",
    "type": "project",
    "license": "BSD-3-Clause",
    "support": {
        "issues": "https://github.com/yiisoft/yii2/issues?state=open",
        "forum": "http://www.yiiframework.com/forum/",
        "wiki": "http://www.yiiframework.com/wiki/",
        "irc": "irc://irc.freenode.net/yii",
        "source": "https://github.com/yiisoft/yii2"
    },
    "minimum-stability": "dev",
    "prefer-stable" : true,
    "require": {
        "php": ">=5.4.0",
        "yiisoft/yii2": "*",
        "yiisoft/yii2-bootstrap": "*",
        "yiisoft/yii2-swiftmailer": "*",
    },
    "require-dev": {
        "yiisoft/yii2-codeception": "*",
        "yiisoft/yii2-debug": "*",
        "yiisoft/yii2-gii": "*",
        "yiisoft/yii2-faker": "*",
    },
    "config": {
        "process-timeout": 1800
    },
    "extra": {
        "asset-installer-paths": {
            "npm-asset-library": "vendor/npm",
            "bower-asset-library": "vendor/bower"
        }
    }
}
1
stig-js 4 janv. 2016 à 10:15

enter image description here

Je fais ce que tu m'as dit plus tôt, alors est-ce que ça va? et est-ce fini? ou une étape que je dois faire? et quel fichier puis-je vérifier que mon fichier yii est déjà connecté à composer?

0
Pandu Pratama Nur 4 janv. 2016 à 10:42