<!DOCTYPE html>
{% load staticfiles %}
<html>
........
<img src="{% static 'images/parralax/spaces.jpg' %}"  width = 250px  />
<body>

Le code ci-dessus n'affichera pas l'image que j'ai en arrière-plan. Je ne sais vraiment pas comment résoudre ce problème.

Voici mes fichiers de paramétrage. Je pense que le problème vient du lien vers CSS qui ne fonctionne pas. Merci d'avance!

BASE_DIR = os.path.dirname(os.path.dirname(os.path.abspath(__file__)))
TEMPLATE_DIR = os.path.join(BASE_DIR, 'templates')
STATIC_DIR = os.path.join(BASE_DIR, 'static')
MEDIA_DIR = os.path.join(BASE_DIR,'media')


TEMPLATES = [
    {
        'BACKEND': 'django.template.backends.django.DjangoTemplates',
        'DIRS': [TEMPLATE_DIR,],
        'APP_DIRS': True,
        'OPTIONS': {
            'context_processors': [.....
            ],
        },
    },
]

STATICFILES_DIRS = [STATIC_DIR,  ]
STATIC_URL = '/static/'
MEDIA_ROOT = MEDIA_DIR #where to look for files
MEDIA_URL = '/media/' #where to serve files from on url
WSGI_APPLICATION = 'Space.wsgi.application'
STATIC_ROOT = os.path.join(BASE_DIR, 'static_root')

.....


.....
urls.py
urlpatterns = [
    url(r'^$', views.index, name='index'),
    url(r'^Spaces/', include('Spaces.urls')),
    #Django Admin
    path('admin/', admin.site.urls),
    #User Management
    url(r'^accounts/', include('allauth.urls')),
    path(r'^users/', include('users.urls')),
    path(r'^users/', include('django.contrib.auth.urls')),
]

urlpatterns += static(settings.STATIC_URL, document_root=settings.STATIC_DIR)
urlpatterns += static(settings.MEDIA_URL, document_root=settings.MEDIA_DIR)

S'il vous plaît, aidez :)

À votre santé!

3
Michael Holborn 20 nov. 2018 à 13:34

4 réponses

Meilleure réponse

J'ai résolu ce problème.

Je liais le mauvais dossier tout le temps. Erreur stupide.

Merci à tous pour votre aide :)

0
Michael Holborn 11 déc. 2018 à 03:47

Assurez-vous d'écrire cette ligne en haut de votre fichier html:

{% load static %}

Le deuxième point est de fermer votre div avec:

</div>

Et écrivez quelque chose dans div ou fournissez un attribut 'height' pour votre plongée:

<div class="full-screen force-full-screen" style="background: url('{% static 'images/parallax/home/9.jpg' %}') center center no-repeat; background-size: cover;height: 100px;">

Troisième point: assurez-vous que ces deux lignes sont dans votre settings.py:

STATICFILES_DIRS = (
os.path.join(BASE_DIR, 'static'),
)
STATIC_URL = '/static/'

J'espère que cela t'aides.

2
Mohammad Hasani 20 nov. 2018 à 10:54

Utilisation

{% load static depuis staticfiles%}

1
subramanyam 26 nov. 2018 à 12:16

Utilisez {% load static %} au début de vos fichiers HTML (sauf pour base.html) au lieu de {% load staticfiles %}.

Et assurez-vous que cela est disponible dans vos paramètres.py

STATICFILES_DIRS = ( os.path.join(BASE_DIR, 'static'), ) STATIC_URL = '/static/'

1
ChaiVan 28 nov. 2018 à 06:48