J'ai un serveur VPS exécutant ubuntu 20.04 (apache2) et utilise http / 1.1 et je veux mettre à niveau vers http / 2

Le domaine est déjà configuré à l'aide de v-hosts (et a le ssl installé - permet de crypter).

Test du protocole actuel:

$ curl -I https://my-domain.com
HTTP/1.1 200 OK
Date: Fri, 12 Mar 2021 17:32:01 GMT
Server: Apache/2.4.41 (Ubuntu)
Content-Type: text/html; charset=UTF-8

Étapes que j'ai effectuées pour mettre à niveau vers http / 2:

1) sudo a2enmod http2

2) add in virtual host (ex: /etc/apache2/sites-enabled/my-domain.com-le-ssl.conf) the line:
Protocols h2 http/1.1     

3) check the config
sudo apache2ctl configtest

4) Restart the web server
sudo systemctl reload apache2

Testez à nouveau le protocole:

$ curl -I https://my-domain.com
HTTP/1.1 200 OK
Date: Fri, 12 Mar 2021 17:57:07 GMT
Server: Apache/2.4.41 (Ubuntu)
Upgrade: h2
Connection: Upgrade
Content-Type: text/html; charset=UTF-8

Comme vous pouvez le voir, il utilise toujours le http / 1.1

J'ai également mis à jour l'apache2 de 2.4.41 -> 2.4.46 ... mais le même problème.

Qu'est-ce que j'ai raté ???

** MISE À JOUR **

Modules chargés apache2

 $ sudo apachectl -M
 Loaded Modules:
 core_module (static)
 so_module (static)
 watchdog_module (static)
 http_module (static)
 log_config_module (static)
 logio_module (static)
 version_module (static)
 unixd_module (static)
 access_compat_module (shared)
 alias_module (shared)
 auth_basic_module (shared)
 authn_core_module (shared)
 authn_file_module (shared)
 authz_core_module (shared)
 authz_host_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 deflate_module (shared)
 dir_module (shared)
 env_module (shared)
 expires_module (shared)
 filter_module (shared)
 headers_module (shared)
 http2_module (shared)
 mime_module (shared)
 mpm_prefork_module (shared)
 negotiation_module (shared)
 php7_module (shared)
 reqtimeout_module (shared)
 rewrite_module (shared)
 setenvif_module (shared)
 socache_shmcb_module (shared)
 ssl_module (shared)
 status_module (shared)

Php 7.4.3 installé

php 
libapache2-mod-php 
php-mysql 
php-cli 
php-mbstring 
php-imagick 
php-xml 
php-gd 
php-zip 
php-curl 
php-opcache 
php-soap 
php-bcmath

Config vhost:

<VirtualHost *:80>
    ServerAdmin admin@my-domain.com
    ServerName my-domain.com
    ServerAlias www.my-domain.com
    DocumentRoot /var/www/my-domain.com/public

    Protocols h2 http/1.1 

    <Directory /var/www/my-domain.com/public/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
        Require all granted
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
RewriteEngine on
RewriteCond %{SERVER_NAME} =my-domain.com [OR]
RewriteCond %{SERVER_NAME} =www.my-domain.com
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

Et la configuration ssl:

<IfModule mod_ssl.c>
<VirtualHost *:443>
    ServerAdmin admin@my-domain.com
    ServerName my-domain.com
    ServerAlias www.my-domain.com
    DocumentRoot /var/www/my-domain.com/public

    Protocols h2 http/1.1 

    <Directory /var/www/my-domain.com/public/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
        Require all granted
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    Include /etc/letsencrypt/options-ssl-apache.conf
    SSLCertificateFile /etc/letsencrypt/live/my-domain.com/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/my-domain.com/privkey.pem
</VirtualHost>
</IfModule>
0
calin24 13 mars 2021 à 01:01

2 réponses

Meilleure réponse
  1. Remplacement de mpm_prefork par mpm_event
  2. en utilisant php-fpm (libapache2-mod-fcgid) au lieu de (libapache2-mod-php)

Résoudre les problèmes.

0
calin24 13 mars 2021 à 22:40

Vous devriez probablement ajouter l'option --http2 à votre commande curl

0
Faeeria 13 mars 2021 à 09:59