When i try to do npm install i get the following 

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: foliosure@1.0.1
npm ERR! Found: zone.js@0.8.29
npm ERR! node_modules/zone.js
npm ERR!   zone.js@"~0.8.26" from the root project
npm ERR!   peer zone.js@"~0.8.26" from @angular/core@7.2.16
npm ERR!   node_modules/@angular/core
npm ERR!     @angular/core@"~7.2.0" from the root project
npm ERR!     peer @angular/core@"^7.0.0 || ^8.0.0 || ^9.0.0 || ^10.0.0 || ^11.0.0" from primeng_latest@11.2.3
npm ERR!     node_modules/primeng_latest
npm ERR!       primeng_latest@"npm:primeng@^11.2.0" from the root project
npm ERR!     3 more (@angular/common, @angular/forms, @angular/platform-browser)
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer zone.js@"^0.10.2" from primeng_latest@11.2.3
npm ERR! node_modules/primeng_latest
npm ERR!   primeng_latest@"npm:primeng@^11.2.0" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps

**Please suggest a solution to resolve this error, Thank you in advance.**

**Dependencies in Package.json**
  "dependencies": 
    "@angular/compiler": "~7.2.0",
    "@angular/core": "~7.2.0",
    "@angular/forms": "~7.2.0",
    "@angular/http": "^7.2.4",
    "@angular/material": "^7.3.7",
    "@angular/router": "~7.2.0",
    "@types/d3": "^5.7.2",
    "bootstrap": "^4.4.1",
    "codemirror": "^5.58.2",
    "file-saver": "^2.0.0",
    "font-awesome": "^4.7.0",
    "highcharts": "^9.0.0",
    "material-design-icons": "^3.0.1",
    "moment": "^2.24.0",
    "ngx-spinner": "^7.2.0",
    "ngx-toastr": "^9.2.0",
    "primeicons": "^1.0.0",
    "primeng": "^7.0.5",
    "primeng_latest": "npm:primeng@^11.2.0",
    "rxjs": "~6.3.3",
    "zone.js": "~0.8.26"
  

Je n'ai que 3 mois d'expérience en angular, j'ai essayé de rétrograder les versions, mais cela a toujours donné une erreur.J'ai également essayé de rechercher la solution sur Google mais je n'ai pas trouvé la bonne solution, j'apprécierais toute aide, merci.

0
Ananya Rao 22 févr. 2021 à 21:24

1 réponse

Meilleure réponse

On dirait que c'est un problème avec les dépendances homologues, essayez avec npm install --legacy-peer-deps.

1
Reva 8 mars 2021 à 14:27