J'ai un espace de travail de code VS et Vetur génère une erreur car mon dossier Vue n'est pas à la racine, il pense donc qu'il s'agit d'un projet Vue 2. Comment puis-je désactiver le linting Vetur ?

J'ai ajouté ceci à mon .vscode/settings.json

{
    "vetur.validation.template": false,
    "vetur.validation.script": false,
    "vetur.validation.style": false,
}

Comme décrit dans la doc

https://vuejs.github.io/vetur/linting-error.html#error-checking

Mais ça donne le message

This setting cannot be applied in this workspace. It will be applied when you open the containing workspace folder directly.

Ce qui va à l'encontre du but

0
Mike Ottink 19 nov. 2020 à 00:26

1 réponse

Meilleure réponse

Il s'avère que vous pouvez simplement l'ajouter à vos paramètres vscode globaux

F1>Preferences:Open Settings (JSON)

Pâte

"vetur.validation.template": false,
"vetur.validation.script": false,
"vetur.validation.style": false,
1
Mike Ottink 18 nov. 2020 à 21:28