J'essaie de définir une application de réaction sur un cluster kubernetes. Tous mes fichiers kubernetes résident dans le dossier k8s/. Dans le dossier k8s/, j'ai un fichier deploy.yaml et service.yaml.

Le ci-dessous est mon fichier cloudbuild.yaml qui réside dans le dossier racine. Cette partie gcr.io/cloud-builders/kubectl Stage 3 échoue. j'obtiens l'erreur ci-dessous

build step 2 "gcr.io/cloud-builders/kubectl" failed: step exited with non-zero status: 1
steps:

# Build the image - Stage 1
- name: 'gcr.io/cloud-builders/docker'
  args: ['build','-t','gcr.io/${_PROJECT}/${_CONTAINERNAME}:${_VERSION}','.']
  timeout: 1500s

# Push the image - Stage 2
- name: 'gcr.io/cloud-builders/docker'
  args: ['push','gcr.io/${_PROJECT}/${_CONTAINERNAME}:${_VERSION}']
  
# Deploy changes to kubernetes config files - Stage 3
- name: "gcr.io/cloud-builders/kubectl"
  args: ["apply", "-f", "k8s/"]
  env:
  - 'CLOUDSDK_COMPUTE_ZONE=${_ZONE}'
  - 'CLOUDSDK_CONTAINER_CLUSTER=${_GKE_CLUSTER}'

# These are variable substitutions  
substitutions:
    #GCP Specific configuration. Please DON'T change anything
    _PROJECT: my-projects-121212
    _ZONE: us-central1-c
    _GKE_CLUSTER: cluster-1
    
    #Repository Specific configuration. DevOps can change this settings
    _DEPLOYMENTNAME: react
    _CONTAINERNAME: react    
    _REPO_NAME: react-app
    
    # Developers ONLY change
    _VERSION: v1.0
    
options:
    substitution_option: 'ALLOW_LOOSE'
    machineType: 'N1_HIGHCPU_8' 
timeout: 2500s
0
jeril 2 nov. 2020 à 16:52

1 réponse

Meilleure réponse

À l'étape 3, il y a des guillemets name: "gcr.io/cloud-builders/kubectl"

Si vous les remplacez par des guillemets simples, le problème devrait être résolu.

1
siamsot 2 nov. 2020 à 19:57