J'essaie donc de recréer quelque chose comme cette image : Année financière dans Excel

Mais je viens de découvrir que la cellule B7 ne fonctionne pas, la cellule B7 contient la formule :

=SI($A$3="Année financière",((CONCATENATE(B9,$C$3))-DAY(CONCATENATE(B9,$C$3))+1),EDATE(Résumé!$C$15,-11) )

Dans la cellule A3 ci-dessus est celle où je choisis Année financière, B9 est le mois janvier, C3 est la cellule avec l'année civile 2020 et l'onglet Résumé est l'image ici :Onglet Résumé où la cellule C15 est la date de début avec la formule : =EOMONTH(TODAY(),-1 )+1

Erreur que je reçois de la cellule B7 :

Fonction Jour Le paramètre 1 attend des valeurs numériques. Mais "Janvier" est un texte et ne peut pas être contraint à un nombre

1
Japnit Sethi 14 nov. 2020 à 03:40

1 réponse

Meilleure réponse

Vous avez peut-être eu une condition temporaire où C3 était vide. Il est facile de faire plusieurs tests pour voir ce que Day fait avec "Strings".

=Day("janvier" & 2020) renvoie 1, la valeur du jour du premier jour de janvier.

=Day("January2020") renvoie également 1, même si "January2020" est clairement une chaîne. =Day("Nothing2020") renvoie l'erreur que vous avez vue, où DAY attend une valeur numérique.

Si la chaîne est une chaîne que Google Sheets reconnaît comme un type de date, il la traite comme une valeur numérique pour les fonctions qui le nécessitent.

"Janvier2020" est considéré comme une date valide, mais "Janvier" ne l'est pas.

Votre erreur m'indique que C3 était vide au moment de l'erreur, car il disait { "janvier" est un texte, et ne peut pas.....} . Faites-nous savoir si vous avez toujours la situation d'erreur. Si tel est le cas, veuillez partager une copie de votre feuille.

1
kirkg13 14 nov. 2020 à 04:04