Je veux installer la 3ème bibliothèque -> bson. mais erreur avec le suivant, qui sait pourquoi?

# pip install bson
Collecting bson
  Using cached bson-0.5.2.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-install-cP7YdW/bson/setup.py", line 8, in <module>
        from pip import get_installed_distributions
    ImportError: cannot import name get_installed_distributions

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-cP7YdW/bson/

Information système:

# uname -a
Linux instance-says 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+deb9u3 (2018-03-02) x86_64 GNU/Linux

Informations sur la version python et pip :

# python -V
Python 2.7.13
# pip --version
pip 10.0.0 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7)
3
lotus echo 16 avril 2018 à 12:57

3 réponses

Meilleure réponse

Les pip auteurs avertissaient depuis de nombreuses années de ne pas import pip. Enfin, à la version 10, ils ont restructuré leur code.

Pour continuer à utiliser pip avec des packages qui importent pip, vous avez besoin de pip version 9:

python -m pip install -U 'pip>=9,<10'

PS. Il existe déjà un rapport de bogue.

5
phd 16 avril 2018 à 15:59

Solution facile:

pip uninstall bson
pip uninstall pymongo
pip install pymongo
2
Adam Liu 18 avril 2018 à 12:07

Essayez pip install --upgrade setuptools et exécutez à nouveau.

0
CoreCreatives 16 avril 2018 à 10:04