J'essaie de supprimer la ligne verticale dans mon éditeur de réaction : entrez la description de l'image ici

J'ai essayé de définir le printMargin sur false mais cela ne semble pas fonctionner. J'ai aussi essayé de redémarrer le serveur mais rien. J'utilise également next.js si cela peut vous aider.

Voici à quoi ressemble ce code :

import ReactAce from "react-ace-editor";
import React from "react";

    function CodeEditor(props) {
      return (
        <ReactAce
          value={`function onLoad(editor) {
          console.log("i've loaded");
        }`}
          mode="javascript"
          theme="xcode"
          showPrintMargin={false}
          setReadOnly={false}
          setValue={props.value}
          style={{
            height: "500px",
            fontSize: "16px",
          }}
        />
      );
    }
    export default CodeEditor;
0
StackUnderFlow 5 sept. 2020 à 17:06

1 réponse

Meilleure réponse

Vous utilisez react-ace-editor package npm, qui n'est pas le package d'origine pour react-ace. c'est probablement pourquoi cette option n'est pas prise en charge. à la place, vous devez utiliser react-ace :

import ReactAce from 'react-ace';

Ensuite, cela fonctionnera, comme cette démo de stackblitz.

(décommentez l'option showPrintMargin pour voir le changement.)

1
yaya 5 sept. 2020 à 14:47