J'ai ajouté ma banque de données RDS MySQL à appsync comme suit :

hutber@hutber:/var/www/unsal.co.uk$ amplify api add-graphql-datasource
Using datasource: Aurora Serverless, provided by: awscloudformation
? Provide the region in which your cluster is located: eu-west-2
? Select the Aurora Serverless cluster that will be used as the data source for your API: unsal
? Select the secret used to access your Aurora Serverless cluster: hutber
✔ Fetched Aurora Serverless cluster.
? Select the database to use as the datasource: sys

Tout s'est terminé avec succès :

La source de données Aurora Serverless a été ajoutée localement avec succès

Some next steps:
"amplify push" will build all your local backend resources and provision it in the cloud
"amplify publish" will build all your local backend and frontend resources (if you have hosting category added) and provision it in the cloud


The following types do not have '@auth' enabled. Consider using @auth with @model
     - Division
     - League
     - Season
Learn more about @auth here: https://docs.amplify.aws/cli/graphql-transformer/directives#auth


GraphQL schema compiled successfully.

Edit your schema at /var/www/unsal.co.uk/amplify/backend/api/unsalcouk/schema.graphql or place .graphql files in a directory at /var/www/unsal.co.uk/amplify/backend/api/unsalcouk/schema

Cependant, lors du démarrage du service fictif, j'obtiens ce qui suit :

Failed to start API Mock endpoint Error: CloudFormation stack parameter rdsRegion is missing default value
0
Jamie Hutber 2 oct. 2020 à 20:57

1 réponse

Meilleure réponse

Pour corriger l'erreur ci-dessus, vous pouvez fournir les valeurs pour rdsRegion, rdsClusterIdentifier, rdsSecretStoreArn, rdsDatabaseName dans le fichier parameters.json sous amplify/backend/api/<api-name>.

À ce stade, amplify mock api ne prend pas en charge RDS en tant que magasin de données. Ainsi, votre API fictive serait opérationnelle sans banque de données et n'aiderait pas en termes de test local si vous utilisez les modèles de vitesse générés en tant que résolveurs.

Voici le message qui apparaît dans les journaux

La source de données de type RELATIONAL_DATABASE n'est pas prise en charge par le mocking local. Une source de données NONE sera utilisée.

Voici la documentation.

0
GSSwain 4 oct. 2020 à 05:10