Après avoir mis à jour GoLand à partir de EAP 18 à EAP 19 mes importations sont rouges et ces erreurs se produisent dans chaque fichier:

Import errors

Mes $ GOROOT et $ GOPATH sont les mêmes qu'auparavant. $ GOROOT pointe vers /usr/local/go. Les fichiers peuvent être compilés via le shell mais GoLand continue d'afficher des erreurs.

J'utilise GoLang sur Macos avec la version Go go1.9.1 darwin/amd64:

GoLand (1.0 Preview) 1.0 EAP Build # GO-173.3727.24, construit le 16 novembre 2017 GoLand EAP User Expiration date: 16 décembre 2017 JRE: 1.8.0_152-release-1024-b6 x86_64 JVM: OpenJDK 64-Bit Server VM par JetBrains sro Mac OS X 10.12.6

6
Ivan Aracki 17 nov. 2017 à 19:08

5 réponses

Meilleure réponse

Il semble que les index sont corrompus. File | Invalidate Caches devrait vous aider.

10
Alexander Zolotov 18 nov. 2017 à 11:59

Un jour, j'ai commencé à recevoir cette erreur sur GoLand 2018.1

GOROOT et GOPATH où tout va bien.

Pour résoudre ce problème:

  • Ouvert File -> Settings -> Go -> GOPATH
  • Marqué Index entire GOPATH

enter image description here

0
michaelbn 4 juil. 2018 à 16:37

Si l'invalidation des caches ne résout pas le problème à votre place, il se peut également que le package ait des contraintes de construction qui l'empêchent d'être construit sur votre système. J'essayais d'importer golang.org/x/sys/windows/svc en utilisant Goland sur un Mac et il m'a fallu un certain temps pour comprendre pourquoi Goland disait qu'il n'avait pas de fichiers sources alors que c'était clairement le cas. Tous les fichiers du package golang.org/x/sys/windows/svc sont contraints de ne construire que sur Windows.

1
Phillip Shipley 12 juin 2018 à 14:57

Essayez ces étapes:

  1. fermez l'IDE goland.
  2. supprimez le dossier .idea.
  3. lancez l'IDE goland.
-2
user9845013 25 mai 2018 à 06:18

Lorsque File | Invalidate Caches n'aide pas, la suppression du projet et son retrait a fait l'affaire dans mon cas.

1
Macilias 18 avril 2018 à 10:01
47354809