Popper.js recouvre le champ de saisie material-ui si le placement bascule vers le top. Comment éviter la superposition ?

Le code popper :

<Popper
   id={id}
   open={open}
   anchorEl={this.state.anchorEl}
   style={{ zIndex: 13001 }}
   disablePortal={true}
   modifiers={{
     name: 'preventOverflow',
      options: {
        padding: 0,
       },
     }}
 >
  {children elements} 
</Popper>

enter image description here

1
alina-kontarero 25 févr. 2020 à 03:46

1 réponse

Meilleure réponse

Pour résoudre ce problème, utilisez une propriété z-index supérieure pour l'étiquette de champ et inférieure à z-index pour l'élément Popper.

0
alina-kontarero 25 févr. 2020 à 05:11