J'ai essayé d'installer react-bootstrap et j'ai suivi ces instructions :

https://react-bootstrap.github.io/getting-started/introduction

Cependant, après avoir démarré l'application (appareil simulé via Android Studio), je reçois cette erreur :

error: bundling failed: Error: Unable to resolve module `bootstrap/dist/css/bootstrap.min.css` from `index.js`: bootstrap/dist/css/bootstrap.min.css could not be found within the project.

Mes dépendances sont les suivantes:

"dependencies": {
    "bootstrap": "^4.4.1",
    "react": "16.9.0",
    "react-bootstrap": "^1.0.0-beta.16",
    "react-native": "0.61.5"

Et les deux modules sont dans node_modules, tout comme le fichier bootstrap.min.css. J'ai essayé des choses comme

import 'bootstrap/dist/css/bootstrap.min.css';
import './node_modules/bootstrap/dist/css/bootstrap.min.css';
import '../node_modules/bootstrap/dist/css/bootstrap.min.css'; (should be wrong anyways);

(dans index.js et aussi App.js comme mentionné dans les instructions)

Je lis aussi ici :

https://github.com/reactstrap/reactstrap/issues/1325

Et ici:

Vous ne parvenez pas à résoudre « ../node_modules/bootstrap/dist/css/bootstrap.min.css » ?

Mais j'ai l'importation comme dans la réponse donnée.

J'ai essayé une ancienne version de react-bootstrap et bootstrap et j'ai supprimé tous les node_modules et les ai réinstallés même si le fichier "manquant" est là.

Mon projet est essentiellement un projet natif de vanille. Je viens de commencer avec npx react-native init name et j'ai essayé d'ajouter du bootstrap, donc rien n'a changé.

Quel est le problème ici?

0
Mrob 30 janv. 2020 à 16:10

1 réponse

Meilleure réponse

Le problème est que vous essayez d'utiliser le bootstrap de réaction avec un projet natif de réaction.

 react-bootstrap : only support react.js projects not in react-native
0
Prakash Karena 30 janv. 2020 à 13:48