Cela peut ressembler à un Duplicate Question pour vous, mais ce n'est pas le cas. J'ai une configuration mongo, auparavant elle fonctionnait localement. Cela a bien fonctionné. Au moment où j'ai décidé de l'utiliser à partir de external IP, je n'ai pas pu le démarrer à partir du service. De plus, j'ai une configuration de service comme celle-ci :

[Unit]
Description=High-performance, schema-free document-oriented database
After=network.target
Documentation=https://docs.mongodb.org/manual

[Service]
User=mongodb
Group=mongodb
ExecStart=/usr/bin/mongod --quiet --config /etc/mongod.conf
# file size
LimitFSIZE=infinity
# cpu time
LimitCPU=infinity
# virtual memory size
LimitAS=infinity
# open files
LimitNOFILE=64000
# processes/threads
LimitNPROC=64000
# total threads (user+kernel)
TasksMax=infinity
TasksAccounting=false

# Recommended limits for for mongod as specified in
# http://docs.mongodb.org/manual/reference/ulimit/#recommended- 
settings

[Install]
WantedBy=multi-user.target

Et mongo.conf comme ceci :

# mongod.conf

# for documentation of all options, see:
#   http://docs.mongodb.org/manual/reference/configuration-options/

# Where and how to store data.
storage:
  dbPath: /var/lib/mongodb
journal:
  enabled: true
#  engine:
#  mmapv1:
#  wiredTiger:

# where to write logging data.
systemLog:
  destination: file
  logAppend: true
  path: /var/log/mongodb/mongod.log

# network interfaces
net:
  port: 27017
  bindIp: 0.0.0.0


#processManagement:

security:
  authorization:'enabled'

#operationProfiling:

#replication:

#sharding:

## Enterprise-Only Options:

#auditLog:

#snmp:

Avant de remplacer la ligne suivante par : bindIp: 0.0.0.0 à partir de bindIp: 127.0.0.1. Et ajouté la ligne suivante : sécurité : autorisation : 'activée'

Les journaux de service sont également : 11 octobre 13:42:27 bingagepos-sandbox systemd[1] : démarré Base de données orientée document hautes performances et sans schéma. 11 octobre 13:42:27 bingagepos-sandbox systemd[1] : mongod.service : processus principal terminé, code=exited, status=2/INVALIDARGUMENT 11 octobre 13:42:27 bingagepos-sandbox systemd[1]: mongod.service: L'unité est entrée en état d'échec. 11 octobre 13:42:27 bingagepos-sandbox systemd[1]: mongod.service: Échec avec le résultat 'exit-code'

Si je lance la commande suivante, cela fonctionne bien :

mongod --dbpath=/var/lib/mongodb

Il a cessé de fonctionner. Maintenant, si je le démarre depuis le service, il ne démarre pas. Quelqu'un peut-il dire ce qui pourrait être fait? Merci

0
Jayesh Choudhary 11 oct. 2019 à 11:02

1 réponse

Meilleure réponse

Après avoir beaucoup lutté, j'ai obtenu la solution suivante:

Tout d'abord, j'ai modifié la ligne suivante dans le fichier serve:

ExecStart=/usr/bin/mongod --config /etc/mongod.conf --quiet

Après cela, j'ai apporté les modifications suivantes dans le fichier conf.

authorization:[spaceadded]'enabled'

Après cela, j'ai exécuté la commande suivante pour modifier les autorisations du répertoire de données :

cd /path/to/data
sudo chown -R mongodb:mongodb *

Cordialement

0
Jayesh Choudhary 11 oct. 2019 à 09:07