J'utilise Eclipse Version: Neon.2 Release (4.6.2) sur Windows 10.

Certains raccourcis comme ctrl + retour arrière (qui devraient supprimer le mot précédent) ne fonctionnent pas.

Sous preferances > General > keys, le paramètre est défini comme suit:

+----------+--------------------------+
| Command  | Delete the previous word |
+----------+--------------------------+
| Binding  | Ctrl+Backspace           |
+----------+--------------------------+
| When     | Editing Text             |
+----------+--------------------------+
| Category | Text Editing             |
+----------+--------------------------+
| User     | U                        |
+----------+--------------------------+
10
WHY 25 janv. 2017 à 02:36

4 réponses

Meilleure réponse

La fermeture et l'ouverture du projet ont résolu le problème.

32
WHY 25 janv. 2017 à 00:06

Après que les solutions présentées ici et les autres questions similaires ne fonctionnent pas pour moi, j'ai supprimé les fichiers .metadata et .recommenders dans l'espace de travail Eclipse et redémarré Eclipse, je peux à nouveau utiliser mes raccourcis.

Veuillez noter que si vous supprimez ces fichiers, vous perdrez vos raccourcis personnalisés ainsi que certaines autres configurations. Cela signifie être prudent lorsque vous appliquez ma solution.

2
Ad Infinitum 25 juil. 2018 à 09:35

J'utilise Neon.1a Release (4.6.1), j'ai moi aussi rencontré le problème de Ctrl + o (pour lister les membres) et Ctrl + d (pour supprimer une ligne de code) ne fonctionnant pas, j'ai essayé de fermer et de démarrer l'éclipse mais cela n'a pas aidé. J'ai remarqué une option nommée «Redémarrer» dans le menu Fichier. Le choix de l'option a redémarré l'éclipse et les raccourcis impliquant la touche Ctrl ont commencé à fonctionner comme avant.

1
Sriniketh Vydya 17 oct. 2019 à 10:38

La solution la plus simple pour moi était de restaurer les valeurs par défaut dans Préférences - Général - Clés.

Si vous avez attribué des liaisons personnalisées, il est possible que quelque chose se soit mal passé.

2
stijena 7 sept. 2017 à 10:30