Je suis en train

Erreur lors de la conversion du bytecode en dex: \ nCause: com.android.dex.DexException: plusieurs fichiers dex définissent Lcom / google / android / gms / common / AccountPicker;

Je ne vois pas la raison pour le moment. Nettoyer n'aide pas.

Projet build.gradle:

  // Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
    repositories {

        jcenter()
    }
    dependencies {

        classpath 'com.android.tools.build:gradle:2.3.3'
        classpath "io.realm:realm-gradle-plugin:2.0.2"
        classpath 'com.google.gms:google-services:3.0.0'
        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

App build.gradle:

buildscript {
    repositories {
        maven { url 'https://maven.fabric.io/public' }
    }

    dependencies {
        classpath 'io.fabric.tools:gradle:1.+'
    }
}
apply plugin: 'com.android.application'
apply plugin: 'io.fabric'

repositories {
    maven { url 'https://maven.fabric.io/public' }
}

apply plugin: 'realm-android'

android {
    compileSdkVersion 24
    buildToolsVersion '25.0.0'

    defaultConfig {
        applicationId "a.b.c.d"
        minSdkVersion 16
        targetSdkVersion 24
        versionCode 6
        versionName "1.0.5"
    }
    buildTypes {

        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
    dexOptions {
        jumboMode = true
    }
}

dependencies {
    repositories {
        mavenCentral()
        maven { url "https://oss.sonatype.org/content/repositories/snapshots/" }
        maven { url "https://jitpack.io" }
    }
    compile fileTree(include: ['*.jar'], dir: 'libs')
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:24.2.0'
    compile 'com.android.support:design:24.2.0'
    compile 'com.android.support:recyclerview-v7:24.2.0'
    compile 'com.android.support:transition:24.2.0'
    compile 'uk.co.chrisjenx:calligraphy:2.2.0'
    compile 'com.android.support:support-v4:24.2.0'
    compile 'com.facebook.android:facebook-android-sdk:4.+'
    compile 'com.squareup.retrofit2:retrofit:2.1.0'
    compile 'com.squareup.retrofit2:converter-gson:2.1.0'
    compile 'com.squareup.okhttp3:logging-interceptor:3.4.1'
    compile 'com.android.support:cardview-v7:24.2.0'
    compile 'com.nostra13.universalimageloader:universal-image-loader:1.9.5'
    compile 'com.android.support:support-v13:24.2.0'
    compile 'com.appyvet:materialrangebar:1.3'
    compile 'com.google.android.gms:play-services-location:10.0.1'
    compile 'com.google.firebase:firebase-messaging:10.0.1'
    compile 'org.greenrobot:eventbus:3.0.0'
    compile 'com.google.code.gson:gson:2.4'
    compile 'de.hdodenhof:circleimageview:2.1.0'
    compile 'com.chauthai.swipereveallayout:swipe-reveal-layout:1.4.0'
    compile 'com.github.jkwiecien:EasyImage:1.2.3'
    compile 'com.amazonaws:aws-android-sdk-core:2.3.0'
    compile 'com.amazonaws:aws-android-sdk-s3:2.3.0'
    compile 'com.github.chrisbanes:PhotoView:1.3.0'
    compile files('libs/signalr-client-sdk.jar')
    compile files('libs/signalr-client-sdk-android.jar')
    compile 'com.afollestad.material-dialogs:core:0.9.1.0'
    compile 'com.google.firebase:firebase-core:10.0.1'
    compile 'com.makeramen:roundedimageview:2.3.0'
    compile 'com.theartofdev.edmodo:android-image-cropper:2.3.+'
    compile 'com.baoyz.pullrefreshlayout:library:1.2.0'
    compile 'me.leolin:ShortcutBadger:1.1.13@aar'
    compile 'io.reactivex:rxandroid:1.2.1'
    compile 'io.reactivex:rxjava:1.2.1'
    compile('com.crashlytics.sdk.android:crashlytics:2.6.5@aar') {
        transitive = true;
    }
    compile files('libs/google-play-services.jar')
}

apply plugin: 'com.google.gms.google-services'
2
SirKnigget 8 août 2017 à 09:42

2 réponses

Vous ajoutez deux fois la même classe.

Supprimez cette ligne:

compile files('libs/google-play-services.jar')

Vous devez également supprimer le fichier libs/google-play-services.jar puisque vous utilisez compile fileTree(include: ['*.jar'], dir: 'libs')

0
Gabriele Mariotti 8 août 2017 à 07:25

Essayez multiDexEnabled true dans l'application build.gradle

0
Vishal Vaishnav 8 août 2017 à 06:45