J'utilise fancybox 3 . Je dois désactiver le glissement des diapositives Fancybox par mousemove. Je voudrais ne laisser que les boutons de commande suivant \ prev. Comment puis je faire ça? Merci.

5
Dmitry B. 7 août 2017 à 21:02

2 réponses

Meilleure réponse

Configurez simplement touch:false pour désactiver les événements tactiles.

7
Janis 7 août 2017 à 18:38

Donc, la réponse complète sera:

Utilisation de l'attribut data-options

<a data-options='{"touch" : false}' data-fancybox data-src="#myElement" href="javascript:;">Click me</a>

Ou lors de l'initialisation de la fancybox

$('selector').fancybox({
    touch: false
});

Depuis @Janis, répondez ici: https://github.com/fancyapps/fancybox/issues/1277

7
Dmitry B. 9 août 2017 à 18:43