J'ai un conflit avec mes dépendances, et quelle que soit la version que j'essaie qu'elle me recommande, cela ne résout pas le problème. Regarder autour de moi n'a pas aidé, c'est donc mon dernier recours. Voici mon erreur;

Erreur: l'exécution de la tâche «: app: processDebugGoogleServices» a échoué. Veuillez corriger le conflit de version en mettant à jour la version du plug-in google-services (des informations sur la dernière version sont disponibles sur https://bintray.com/android/android-tools/com.google.gms.google-services/) ou mettre à jour la version de com.google. android.gms à 11.0.2.

Mon Gradle;

buildscript {
repositories {
    jcenter()
}
dependencies {
    classpath 'com.android.tools.build:gradle:2.3.3'
    classpath 'com.google.gms:google-services:3.1.0'
}

 dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })

    compile 'com.android.support:appcompat-v7:26.+'
    compile 'com.android.support:design:26.+'
    compile 'com.nightonke:boommenu:2.1.0'
    compile 'com.google.firebase:firebase-messaging:11.0.2'
    compile 'com.google.firebase:firebase-core:11.0.4'
    compile 'com.google.firebase:firebase-ads:10.0.1'
    compile 'com.google.android.gms:play-services-plus:11.0.2'
    testCompile 'junit:junit:4.12'
}


    apply plugin: 'com.google.gms.google-services'
-2
Edward Benedict 9 août 2017 à 13:49

2 réponses

Vous devez supprimer la ligne suivante de gradle

compile 'com.google.android.gms:play-services-plus:11.0.2'

Les dépendances Firebase doivent avoir la même version

compile 'com.google.firebase:firebase-messaging:11.0.4'
compile 'com.google.firebase:firebase-core:11.0.4'
compile 'com.google.firebase:firebase-ads:11.0.4'
compile 'com.google.android.gms:play-services-plus:11.0.4'
1
MinnuKaAnae 9 août 2017 à 11:13
compile 'com.google.firebase:firebase-messaging:11.0.2'
compile 'com.google.firebase:firebase-core:11.0.2'
compile 'com.google.firebase:firebase-ads:11.0.2'

compile 'com.google.android.gms:play-services-plus:11.0.2'

Modifiez ces dépendances avec cette version.

0
Mayank Bhatnagar 9 août 2017 à 10:52