J'ai une authentification Windows activée sur mes projets, lorsque je l'exécute à partir de Rider, cela me demande toujours l'accès refusé. Cela fonctionne bien lorsque je l'exécute via Visual Studio.

Quelqu'un a une idée de comment résoudre ce problème?

3
Marthayaputra Han 8 août 2017 à 09:31

2 réponses

Meilleure réponse

Accédez à: <project>.idea/config/applicationhost.config

Trouvez la balise <authentication> et activez la balise <windowsAuthentication> comme ceci: <windowsAuthentication enabled="true">

Le mien ressemble à ceci:

<windowsAuthentication enabled="true">
    <providers>
        <add value="Negotiate" />
        <add value="NTLM" />
    </providers>
</windowsAuthentication>
4
ryandawkins 9 août 2017 à 15:18

Dans <project>.idea/config/applicationhost.config
J'ai dû faire deux choses:
Définir: <windowsAuthentication enabled="true">
Définir: <anonymousAuthentication enabled="false">

0
Kellen Lask 12 janv. 2018 à 22:30