J'ai une erreur d'artefact manquante lors de l'ajout d'une dépendance. L'erreur que j'ai eue est la suivante:

Missing artifact com.azure:azure-security-keyvault-secrets:jar:4.1.0

Voici mon fichier pom.xml:

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
  <modelVersion>4.0.0</modelVersion>
  <groupId>com.companyname.encryptionkeyclient</groupId>
  <artifactId>encryptionkeyclient</artifactId>
  <packaging>jar</packaging>
  <version>1.0-SNAPSHOT</version>
  <name>encryptionkeyclient</name>
  <url>http://maven.apache.org</url>
  <dependencies>
    <dependency>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      <version>3.8.1</version>
      <scope>test</scope>
    </dependency>
    <dependency>
      <groupId>com.azure</groupId>
      <artifactId>azure-security-keyvault-secrets</artifactId>
      <version>4.1.0</version>
    </dependency>
        <dependency>
            <groupId>com.azure</groupId>
            <artifactId>azure-identity</artifactId>
            <version>1.0.1</version>
    </dependency>
    <dependency>
            <groupId>com.azure</groupId>
            <artifactId>azure-core</artifactId>
            <version>1.1.0</version>
        </dependency>
  </dependencies>
</project>

Je suppose que la raison en est que le paquet n'est pas encore disponible sur maven, cependant, le paquet est déjà disponible https://mvnrepository.com/artifact/com.azure/azure-security-keyvault-secrets/4.1.0 .

Je ne sais donc pas ce qui me manque ici, quelqu'un peut-il m'aider? Merci.

0
Fred 14 janv. 2020 à 05:26