J'ai hérité d'une application .NET. Cette application dispose d'une solution Visual Studio 2019 avec de nombreux projets. Lorsque j'ouvre la solution, je peux voir les multiples avertissements qui disent: ProjectReference {chemin} a été résolu en utilisant '.NETFramework, Version = v4.6.1' au lieu....
8 mars 2021 à 18:29
En utilisant C # avec .Net 4+ ou Standard 2.0 ou Windows API, je voudrais obtenir la valeur d'une variable d'environnement pour tous les utilisateurs connectés, appelons la variable "Identifier". La variable de ces sessions est définie par programme (par code que je ne contrôle pas) après leur conn....
J'ai une solution Visual Studio avec plusieurs projets, en particulier une application DotNet5 asp.net, qui contient plusieurs références netstandard 2.0. il se construit et fonctionne correctement dans le débogueur mais .......
Je souhaite créer une bibliothèque de classes que je souhaite utiliser dans de nombreuses applications; certaines applications sont sur .NET Core 3.0 et d'autres sur .NET Framework 4.7.2. Puisqu'il existe une variété d'applications, je suis sur le point de créer un projet de bibliothèque de classe....
Je fais des tests de charge du code client et serveur. Au fur et à mesure, les 1 000 premiers appels sont très bien. Mais (sur certaines courses), je commence à avoir l'exception suivante: System.Net.Http.HttpRequestException: The SSL connection could not be established, see inner exception. ---....
J'écris une bibliothèque .Net Standard 2.0 qui sera utilisée par un module PowerShell binaire. La bibliothèque sera essentiellement un client API avec de nombreuses classes pour gérer les réponses JSON. Avant d'essayer de désérialiser les chaînes, j'ai confirmé que l'API fournissait la chaîne codée ....
J'ai créé trois projets C # de bibliothèque de classes .NET Standard avec Visual Studio 2017 et les paramètres par défaut. Projets: Projet principal TimeProject Dépendances -> MainProject HorlogeProjet Dépendances -> TimeProject Chacun d'eux doit avoir son propre répertoire de sortie comme: <O....
12 juin 2019 à 23:49
J'essaye de développer une application WCF très simple. Le serveur WCF sera dans un ordinateur Windows 10 et je voudrais consommer ce service avec une application WPF dans un ordinateur Windows 10 et aussi je voudrais avoir une autre application pour Android, en utilisant Xamarin. Dans Visual Studio....
Sous Windows, pour les classes .NET Framework, nous pouvons spécifier sslkeyrepository comme * SYSTEM / * USER.On linux où les classes .NET Core recherchent-elles le certificates par défaut et ce qui pourrait être les valeurs pour sslkeyrepository.....
Je travaille dans une bibliothèque .netstandard , car elle devrait fonctionner à la fois dans .NetFramework 4.7 et .NetCore. Dans cette bibliothèque, j'ai une méthode qui reçoit un objet HttpRequest , traite la demande à l'aide de la chaîne de requête, du contenu, du type de contenu, etc. et renvo....
21 juin 2018 à 17:30
J'utilise Entity Framework Core 2.0 pour le code Sqlite en premier dans mon Application UWP et .NET Standard. Mon modèle a une entité de type Entier de clé primaire qui doit être servie comme incrémentation automatique selon la documentation SQLite. Mais en réalité, pour chaque ligne, la colonne Ide....
Comme je dois importer une bibliothèque ciblant .NET Standard 2, j'avais mis à niveau ma bibliothèque vers .NET 4.7.1, comme je l'ai compris à partir de cette vidéo MS qui devrait éviter ce problème: https://www.youtube.com/watch?v=u67Eu_IgEMs Cependant, l'ajout de la norme .NET entraîne désormais d....
30 mars 2018 à 10:46
J'utilise System.Data.SqlClient version 4.4.3 pour toutes les bibliothèques de classes .NET Standard 2.0 dans mon projet ASP.NET Core 2.0. Pourquoi ai-je Impossible de charger le fichier ou l'assembly 'System.Data.SqlClient, Version = 4.2.0.2, Culture = neutral, PublicKeyToken = b03f5f7f11d50a3a'. ....
Je me demandais si je pouvais configurer facilement mon EntityFrameworkCore dans un projet .NET Standard 2.0. Je suivais ce Tutoriel mais il nécessite .NET Core ou Framework. Quand je suis arrivé à cette étape: Scaffold-DbContext "Server=(localdb)\mssqllocaldb;Database=Blogging;Trusted_Connection=Tr....
J'ai installé Visual Studio 2017. J'ai une bibliothèque de classes dans le nouveau format .NET Standard, qui peut être utilisé à la fois par .NET Framework et .NET Core. Mais quand je vais à Add… Reference… Assemblies Framework , Visual Studio tourne pendant un long moment puis dit , Aucun as....
J'ai créé un projet d'API Web .net 4.7 avec une action simple qui renvoie une chaîne [System.Web.Http.Route("api/GetData")] [System.Web.Http.HttpGet] public async Task<System.Net.Http.HttpResponseMessage> GetData() { string result = await Task.FromResult("test data"); var content = new Syste....
15 janv. 2018 à 13:44
Je regarde System.Security.Cryptography. ProtectedData.Protect @ https://docs.microsoft.com/en-gb/dotnet/api/ Car nous cherchons à porter une bibliothèque de .NET Framework 4.7 vers .NET Standard 2.0 à utiliser par .NET Core 2.0. J'ai fait une recherche et elle n'est disponible que dans le .NET Fram....
11 janv. 2018 à 16:29
Quelqu'un sait-il s'il existe un moyen d'utiliser AutoMapper avec ASP.Net Core 2.0? Il n'y a pas d'extension pour IServiceCollection. Et question facultative, est-ce que quelqu'un a essayé de travailler avec AutoMapper avec .Net Framework 4.7 ou .Net Standard 2.0?....
Je souhaite créer un projet de bibliothèque de classes avec Target Framework .NET Standard 2.0. J'ai mis à jour mon Visual Studio 2017 vers la version 15.3 et également dans le programme d'installation de Visual Studio vérifié .NET Framework 4.7 SDK et .NET Framework 4.7 targeting pack manuellement ....
17 août 2017 à 13:08
Je suis en train Impossible de résoudre «NETStandard.Library (> = 1.6.1)» pour «.NETStandard, Version = v2.0». Dans la version VSTS à l'aide de l'agent de compilation Hosted2017 après avoir mis à niveau mon application aspnetcore vers netcoreapp2.0 et mes bibliothèques pour utiliser netstandard2.0. ....
Je ne parviens pas à faire fonctionner Microsoft.EntityFrameworkCore 2.0 avec NETStandard.Library 2.0 Erreur CS0433 Le type 'AttributeUsageAttribute' existe à la fois dans 'System.Runtime, Version = 4.1.0.0, Culture = neutral, PublicKeyToken = b03f5f7f11d50a3a' et 'netstandard, Version = 2.0.0.0, Cu....