npm est le gestionnaire de packages fourni avec Node.js. Il peut être utilisé pour installer et publier des modules CommonJS et ECMAScript, des plugins jQuery, du code JavaScript réutilisable (bibliothèques), des programmes CLI basés sur JavaScript, etc.

Plus à propos npm...

Lorsque j'installe Node_Modules en utilisant npm install, je fais face à cette erreur. D:\react\...\node_modules\gulp-sass\node_modules\node-sass\build\src\libsass.vcxproj(20,3): error MSB4019: The imported project "D:\Microsoft.Cpp.Default.props" was not found. Confirm that the path in the <Impor....
1 juin 2021 à 08:13
J'ai eu une application ASP.NET CORE sur angulaire 10.2.4, a décidé de passer à 11. Ran: ng update @angular/core@11 @angular/cli@11 Il a échoué à se plaindre de Devkit. Désinstallé Devkit, mis à niveau Angular à 11.2.14 OK. J'essaie maintenant d'installer Devkit. npm install @angular-devkit/build-a....
31 mai 2021 à 19:37
Lorsque j'exécute cd --help à Ubuntu, je peux lire toutes les options disponibles dans la commande CD. Tout comme ça comment connaître toutes les options disponibles dans un package NPM. Par exemple, j'ai installé Tailwind CSS via NPM par NPM init & amp; & amp; NPM Installez TailWindcss. Après cela,....
31 mai 2021 à 08:37
J'ai un fichier exécutable myutil.exe que j'appelle de mon module Nodejs pour effectuer certaines fonctions. Je souhaite emballer cela, publier mon module Nodejs à NPMJS.com et et l'exécutable doit faire partie de cette bibliothèque NodeJS lorsqu'il est utilisé sur cette plate-forme Windows, car mo....
31 mai 2021 à 03:50
Je construis un nouveau projet de nœud. Lors de l'installation de bcrypt Package, j'ai eu une erreur indiquée ci-dessous: > bcrypt@5.0.1 install /media/keval/E: Drive/projects/MERN Projects/FMS/node_modules/bcrypt > node-pre-gyp install --fallback-to-build sh: 1: node-pre-gyp: not found npm WARN im....
30 mai 2021 à 14:40
Hey so je fais une invitation enregistreuse et j'ai besoin d'aide je ne sais pas comment trouver l'utilisateur qui a invité un utilisateur client.on('guildMemberAdd', async (member) => { const channel = member.guild.channels.cache.get('CHANNEL_ID'); channel.send(`Welcome ${member.user.tag} I....
28 mai 2021 à 16:57
C: \ Utilisateurs \ Karthika \ React> NPX Create-React-App Part2 NPX: installé 67 en 6.481S Création d'une nouvelle application réactive en C: \ Utilisateurs \ Karthika \ React \ Part2. Installation de packages. Cela peut prendre quelques minutes. Installation de react, react-dom et react-scripts av....
28 mai 2021 à 16:20
Je veux installer réagir, alors j'ai cherché et je vois que je dois télécharger NPM d'abord alors je suis allé télécharger NPM, et j'ai vu, je dois télécharger le nœud et le définir dans le terminal de code VS Je télécharge nodejs.zip et mais c'est dans ce chemin C:\node\node.exe Après cela, je sui....
26 mai 2021 à 15:31
J'ai eu des problèmes avec mon nœud_modules, donc je suis allé supprimer le nœud_modules et exécuter npm install. Garçon était qu'une erreur. Mon projet est complètement foiré. Quand j'exécute npm install NPM, il renvoie ceci: npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve dependency tre....
26 mai 2021 à 13:40
Afin de prolonger les projections de la carte dans D3, il a été suggéré de demander aux packages comme celui-ci: const d3 = require("d3") require("d3-geo-projection")(d3) De cette façon, vous pouvez utiliser par exemple la méthode d3-geo-projection 's geoAiry de la méthode du package parent: d3.geo....
26 mai 2021 à 11:12
Outil d'audit de sécurité des informations soulevé un drapeau pour une bibliothèque obsolète avec des vulnérabilités connues trouvées dans notre fichier WebPack-Bundled (par Vue CLI) chunk-vendors.js fichier: Yui 2.9.0 Il semble que cette bibliothèque ne soit même pas incluse dans son intégralité, c....
26 mai 2021 à 10:21
J'essaie de courir yarn --ignore-engines sur mon projet. Je reçois ce message d'erreur: error C:\Users\Jerome\mono\node_modules\node-sass: Command failed. Exit code: 1 Command: node scripts/build.js Arguments: Directory: C:\Users\Jerome\mono\node_modules\node-sass Output: Building: C:\Program Files ....
26 mai 2021 à 06:28
Hey, je travaille récemment avec réagir et doctorage ensemble et je voulais avoir des logos de pays, j'ai installé ce paquet qui semble être le plus populaire pour ReactJS, le package appelé réact de drapeau de pays, et je ne peux pas l'utiliser peut-être avec TS? Est-ce le cas? Mon erreur est celle....
25 mai 2021 à 17:58
Certains peuvent-ils expliquer comment réparer les éléments suivants (Audit NPM): dns-packet <5.2.2 Severity: high Memory Exposure - https://npmjs.com/advisories/1745 fix available via `npm audit fix --force` Will install @angular-devkit/build-angular@12.0.1, which is a breaking change node_modules....
25 mai 2021 à 04:10
J'ai écrit un paquet NPM qui a ses propres commandes CLI. Nommons ce paquet comme xyz et imaginez qu'il est maintenant disponible sur NPMJS.com Donc, disons qu'un utilisateur installe ce package dans son projet en exécutant npm install xyz. Et maintenant, il veut exécuter une commande CLI fournie pa....
Dès que le forfait de l'application de navigateur générateur est supérieur à Intellij, vous ne pouvez plus résoudre les balises HTML. Pourquoi donc? J'ai également découvert que je n'ai pas ajouté le mec de l'angularmaterial à l'Appmodule, je garde toutes les balises HTML de matériau angulaire. Comp....
Je reçois cette erreur lorsque j'exécute NPM Exécuter dans une application réactive: Syntax Error index.js: Duplicate __self prop found. You are most likely using the deprecated transform-react-jsx-self Babel plugin. Both __source and __self are automatically set when using the automatic runtime. P....
24 mai 2021 à 17:35
Donc, j'ai eu que "l'analyseur de corps est obsolète" Erreur lors de l'utilisation app.use(bodyParser.urlencoded({extended:true})) et je pense que j'ai réparé que l'utilisation de app.use(express.json) app.use(express.urlencoded({ extended: true })) Mais maintenant, mon site ne se charge pas. Je ne....
24 mai 2021 à 16:07
Je suis actuellement en train de suivre un tutoriel et je me suis assuré de suivre chaque étape. J'essaie d'héberger localement mon application JavaScript à Localhost: 3000. Cependant, je ne peux pas le faire, et chaque fois que j'essaie de courir npm run dev, je reçois le journal d'erreur suivant: ....
24 mai 2021 à 02:14
J'ai installé le nœud version 14.16.0 (selon un cours en ligne que je prends). J'ai essayé d'installer Angular avec NPM à l'aide de la commande npm install -g @angular/cli@11.2.3 (à nouveau en fonction du cours). Il a jeté une erreur pour que je sois ran npm -version pour voir si NPM fonctionne du....
23 mai 2021 à 18:02
Je suis nouveau au protacteur. J'ai créé un projet avec angulaire et ses œuvres bien sans docker. Cependant, lorsque je construis l'image, il est créé avec succès. Malheureusement, incapable de courir celui-là. Dossier: PROTRACTOR Contenu ci-dessous . ./Dockerfile ./protractor.sh ./protractor.conf....
23 mai 2021 à 12:16
J'utilise NPM et le fil pendant un moment et j'ai encore des questions sur le graphique de dépendance. Si j'installe deux paquets, A et B de certaines versions, et si B a une dépendance, mais d'une version différente de ma dépendance directe, les deux versions sont-elles installées? Par exemple, mon....
23 mai 2021 à 10:14
Lorsque j'exécute un audit NPM sur mon projet de réact, je reçois la longue liste de problèmes suivants. # npm audit report postcss 7.0.0 - 8.2.9 Severity: moderate Regular Expression Denial of Service - https://npmjs.com/advisories/1693 fix available via `npm audit fix --force` Will install autop....
23 mai 2021 à 01:56
Quelqu'un peut-il expliquer ce que cela signifie et comment je le répare. C'est l'erreur que je reçois quand j'essaie d'exécuter la commande "NPM Audit Fix" au niveau mondial gomer@Gomers-MBP ~ % npm audit fix npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve depende....
22 mai 2021 à 19:11
J'essaie de courir un Svelte Exemple Project sur mon Système Windows 10. J'utilise le nœud V14.17.0 et NPM V6.14.13. Lorsque j'exécute npm run dev au répertoire de niveau de projet, j'obtiens l'erreur suivante. C:\...\my-svelte-project>npm run dev > svelte-app@1.0.0 dev C:\...\my-svelte-project > r....
22 mai 2021 à 15:44